Installing Unity
Unity Hub

System requirements for Unity 2019.3

This page outlines the minimum system requirements you need to run Unity 2019.3 on all supported platforms.

  1. Unity Editor system requirements
  2. Unity Player system requirements

Unity Editor system requirements

This section lists the minimum requirements to run the Unity Editor. Actual performance and rendering quality may vary depending on the complexity of your project.

Minimum requirements Windows macOS Linux (Support in Preview)
Operating system version Windows 7 and Windows 10, 64-bit versions only. Sierra 10.12.6+ Ubuntu 16.04, Ubuntu 18.04, and CentOS 7
CPU X64 architecture with SSE2 instruction set support X64 architecture with SSE2 instruction set support X64 architecture with SSE2 instruction set support
Graphics API DX10, DX11, and DX12-capable GPUs Metal-capable Intel and AMD GPUs OpenGL 3.2+/ Vulkan-capable, Nvidia and AMD GPUs.
Additional requirements Hardware vendor officially supported drivers Apple officially supported drivers Gnome desktop environment running on top of X11 windowing system, Nvidia official proprietary graphics driver or AMD Mesa graphics driver. Other configuration and user environment as provided stock with the supported distribution (Kernel, Compositor, etc.)
For all operating systems, the Unity Editor is supported on workstations or laptop form factors, running without emulation or compatibility layer.

Unity Player system requirements

This section lists the minimum requirements to build and run the Unity Player. Actual performance and rendering quality may vary depending on the complexity of your project.

Mobile

Operating system Android iOS tvOS
Version 4.4 (API 19)+ 10+ 10+
CPU ARMv7 with Neon Support (32-bit) or ARM64 A6/A6X SoC+ A8 SoC+
Graphics API OpenGL ES 2.0+, OpenGL ES 3.0+, Vulkan Metal,
OpenGL ES 2.0/3.0 (Deprecated)
Metal,
OpenGL ES 2.0/3.0 (Deprecated)
Additional requirements 1GB+ RAM.
Supported hardware devices must meet or exceed Google’s Android Compatibility Definition (Version 9.0) limited to the following Device Types:
1. Handheld (Section 2.2)
2. Television (Section 2.3)
3. Tablets (Section 2.6)
Hardware must natively be running Android OS. Android within a Container or Emulator is not supported.
For Development: Android SDK (9/API 28), Android NDK (r19) and OpenJDK, which are installed by default with Unity Hub
For development: Mac computer running minimum macOS 10.12.6 and Xcode 9.4 or higher. Apple TV 4th generation+

Console

For PlayStation 4 (including PS VR), Xbox One and Nintendo Switch, see the Unity for console section on the Unity Mulitplatform page.

Desktop

Operating system Windows Universal Windows Platform macOS Linux
Operating system version Windows 7 and Windows 10. Workstation, laptop and tablet form factors, running on device without emulation or compatibility layer. Xbox One, Hololens, workstation, laptop and tablet form factors, running on device without emulation or compatibility layer. Sierra 10.12+ running on workstation and laptop form factors, without emulation or compatibility layer. Ubuntu 16.04, Ubuntu 18.04, running on workstation and laptop form factors, without emulation or compatibility layer.
CPU x86, x64 architecture with SSE2 instruction set support. x86, x64 architecture with SSE2 instruction set support, ARM, ARM64. x64 architecture with SSE2. x64 architecture with SSE2 instruction set support.
Graphics API DX10, DX11, DX12 Capable. DX10, DX11, DX12 Capable GPUs. Metal capable Intel and AMD GPUs OpenGL 3.2+ / Vulkan capable.
Additional requirements Hardware vender officially support drivers. Hardware vendor officially supported drivers.
For development: Windows 10 (64-bit), Visual Studio 2015 with C++ Tools component or later and Windows 10 SDK.
Apple officially supported drivers. Gnome desktop environment running on top of X11 windowing system
Other configuration and user environment as provided stock with the supported distribution (Kernel, Compositor, etc.)
Nvidia and AMD GPUs using Nvidia official proprietary graphics driver or AMD Mesa graphics driver.

Stadia

Unity developers interested in bringing games to the Stadia platform should start by applying for development resources on Google’s Stadia developer website.

Server platform

Operating system Windows macOS Linux
Operating system version Windows 7 and 10, running on workstation and rack form factors, without emulation or compatibility layer. Sierra 10.12+ running on workstation and rack form factors, without emulation or compatibility layer. Ubuntu 16.04, 18.04, running on workstation and rack form factors, without emulation or compatibility layer.
CPU x86, x64 architecture with SSE2 instruction set support. x64 architecture with SSE2 instruction set support. Architecture with SSE2 instruction set support.
GPU No explicit GPU support.
Additional requirements Hardware vendor officially supported drivers.

WebGL

Operating system running browsers Windows, macOS, and Linux
Hardware Workstation and laptop form factors.
Additional requirements Versions of Chrome, Firefox or Safari that are:
- WebGL 1.0 or 2.0 capable
- HTML 5 standards compliant
- 64-bit
- WASM capable

XR platform system requirements

As part of the migration to the Unity XR plugin architecture using the XR Management package, built-in platform packages will be deprecated in Unity 2019.3 and newer versions.

These implementations are still functional and available in the Unity Package Manager, but bugs and issues might not be prioritized and the package will be removed in future releases.

For Google Daydream/Cardboard, OpenVR, and Vuforia support options in Unity 2019.3+, see the XR plugin architecture page.

Oculus

This includes system requirements for Oculus Rift/Rift S, Oculus Go, Oculus Quest, and Samsung Gear VR.

Hardware Oculus Rift/Rift S Oculus Go Oculus Quest Samsung Gear VR
Operating system version Windows 10 Android Android Samsung Android 5.0/Lollipop+
CPU Intel 64-bit ARM 64-bit (Snapdragon 821) ARM 64-bit (Snapdragon 835) ARM 64-bit (Snapdragon 821)
GPU NVIDIA GTX 1050Ti/AMD Radeon RX 470 or greater 該当なし
Graphics API DX11, OpenGL OpenGL ES 3.0+, Vulkan OpenGL ES 3.0, Vulkan OpenGL ES
Additional requirements Latest Supported SDK Version: 1.38.
Use the XR Management and Oculus XR Plugin packages.

Windows Mixed Reality

This includes system requirements for WMR Immersive (VR), HoloLens, and HoloLens Remoting.

Hardware WMR Immersive (VR) HoloLens HoloLens Remoting
Operating system version Windows 10 RS4 Windows Holographic Windows 10 RS4
CPU Intel 64-bit Intel Atom Intel 64-bit
Graphics API DX11 該当なし
Additional requirements Supported SDK Version: 10.0.17134.0.
Use the XR Management and Windows XR Plugin packages.

Magic Leap

This includes system requirements for Magic Leap One and Magic Leap Remoting.

Operating system Magic Leap One Magic Leap Remoting
Operating system version Lumin OS Windows 10 RS3, macOS El Capitan 10.11.6+
CPU Nvidia Tegra X2 Intel 64-bit
GPU 該当なし Nvidia, AMD
Graphics API OpenGL ES 3.2+ 該当なし
Additional requirements Latest supported SDK Version: 0.18.0

ARCore

This includes system requirements for Android Phones, iPhone and iPad.

Operating system Android phones iPhone and iPad
Operating system version 7 iOS 11
CPU ARM 64-bit A9+
Graphics API OpenGL ES Metal
Additional requirements Latest supported SDK Version: 1.9

ARKit

This includes system requirements for iPhone and iPad.

Operating system iPhone and iPad
Operating system version iOS 11
CPU A9+
Graphics API Metal
Additional requirements Latest supported SDK Version: ARKit 3 beta

Other system requirements notes

For any Unity Editor or Player supporting Windows 7, note that Microsoft support for Windows 7 expires after January 14th 2020.

Installing Unity
Unity Hub