Version: 2019.3
Unity 설치
Unity 허브

Unity 2019.3의 시스템 요구 사항

이 페이지에는 모든 지원되는 플랫폼에서 Unity 2019.3을 실행하는 데 필요한 최소 시스템 요구 사항이 간략하게 나와 있습니다.

  1. Unity 에디터 시스템 요구 사항
  2. Unity 플레이어 시스템 요구 사항

Unity 에디터 시스템 요구 사항

이 섹션에는 Unity 에디터를 실행하는 데 필요한 최소 요구 사항이 나와 있습니다. 실제 성능과 렌더링 품질은 프로젝트의 복잡도에 따라 다를 수 있습니다.

최소 요구 사항 Windows macOS Linux(프리뷰에서 지원)
운영체제 버전 Windows 7 및 Windows 10, 64비트 버전만 사용 가능. Sierra 10.12.6+ Ubuntu 16.04, Ubuntu 18.04 및 CentOS 7
CPU SSE2 명령어 집합 지원이 포함된 X64 아키텍처 SSE2 명령어 집합 지원이 포함된 X64 아키텍처 SSE2 명령어 집합 지원이 포함된 X64 아키텍처
그래픽스 API DX10, DX11 및 DX12 지원 GPU Metal 지원 Intel 및 AMD GPU OpenGL 3.2+/ Vulkan 지원 Nvidia 및 AMD GPU.
추가 요구 사항 하드웨어 공급업체가 공식적으로 지원하는 드라이버 Apple이 공식적으로 지원하는 드라이버 X11 윈도잉 시스템을 기반으로 동작하는 Gnome 데스크톱 환경, Nvidia 공식 전용 그래픽스 드라이버 또는 AMD Mesa 그래픽스 드라이버. 지원되는 배포와 함께 제공되는 기타 설정 및 사용자 환경(Kernel, Compositor 등)
모든 운영체제에서 Unity 에디터는 에뮬레이션 또는 호환성 레이어 없이 실행되는 워크스테이션 또는 노트북 폼 팩터에서 지원됩니다.

Unity 플레이어 시스템 요구 사항

이 섹션에는 Unity 플레이어를 빌드하고 실행하는 데 필요한 최소 요구 사항이 나와 있습니다. 실제 성능과 렌더링 품질은 프로젝트의 복잡도에 따라 다를 수 있습니다.

모바일

운영체제 Android iOS tvOS
Version 4.4 (API 19)+ 10+ 10+
CPU Neon 지원 ARMv7(32비트), 또는 ARM64 A6/A6X SoC+ A8 SoC+
그래픽스 API OpenGL ES 2.0+, OpenGL ES 3.0+, Vulkan Metal,
OpenGL ES 2.0/3.0(지원 중단 예정)
Metal,
OpenGL ES 2.0/3.0(지원 중단 예정)
추가 요구 사항 1GB+ RAM.
지원되는 하드웨어 기기는 다음 기기 타입으로 제한된 Google의 Android 호환성 정의(버전 9.0)를 충족하거나 초과해야 합니다.
1. 휴대용 기기(섹션 2.2)
2. 텔레비전(섹션 2.3)
3. 태블릿(섹션 2.6)
하드웨어는 네이티브 방식으로 Android OS를 실행해야 합니다. 컨테이너 또는 에뮬레이터 내 Android는 지원되지 않습니다.
개발용: Android SDK (9/API 28), Android NDK (r19) 및 OpenJDK(Unity Hub에서 기본적으로 설치됨)
개발용: 최소 macOS 10.12.6 및 Xcode 9.4 이상을 실행하는 Mac 컴퓨터 Apple TV 4세대 이상

콘솔

PlayStation 4(PS VR 포함), Xbox One 및 Nintendo Switch의 경우 Unity 멀티 플랫폼 페이지의 콘솔용 Unity 섹션을 참조하십시오.

데스크톱

Operating system Windows Universal Windows Platform macOS Linux
Operating system version Windows 7 and Windows 10. Workstation, laptop and tablet form factors, running on device without emulation or compatibility layer. Xbox One, Hololens, workstation, laptop and tablet form factors, running on device without emulation or compatibility layer. Sierra 10.12+ running on workstation and laptop form factors, without emulation or compatibility layer. Ubuntu 16.04, Ubuntu 18.04, running on workstation and laptop form factors, without emulation or compatibility layer.
CPU x86, x64 architecture with SSE2 instruction set support. x86, x64 architecture with SSE2 instruction set support, ARM, ARM64. x64 architecture with SSE2. x64 architecture with SSE2 instruction set support.
Graphics API DX10, DX11, DX12 Capable. DX10, DX11, DX12 Capable GPUs. Metal capable Intel and AMD GPUs OpenGL 3.2+ / Vulkan capable.
Additional requirements Hardware vender officially support drivers. Hardware vendor officially supported drivers.
For development: Windows 10 (64-bit), Visual Studio 2015 with C++ Tools component or later and Windows 10 SDK.
Apple officially supported drivers. Gnome desktop environment running on top of X11 windowing system
Other configuration and user environment as provided stock with the supported distribution (Kernel, Compositor, etc.)
Nvidia and AMD GPUs using Nvidia official proprietary graphics driver or AMD Mesa graphics driver.

Stadia

Stadia 플랫폼에 게임을 출시할 생각이 있는 Unity 개발자들은 Google의 Stadia 개발자 웹사이트에서 개발 리소스를 신청해야 합니다.

서버 플랫폼

운영체제 Windows macOS Linux
운영체제 버전 에뮬레이션 또는 호환성 레이어 없이 워크스테이션 및 랙 폼 팩터에서 실행되는 Windows 7 및 10 에뮬레이션 또는 호환성 레이어 없이 워크스테이션 및 랙 폼 팩터에서 실행되는 Sierra 10.12+ 에뮬레이션 또는 호환성 레이어 없이 워크스테이션 및 랙 폼 팩터에서 실행되는 Ubuntu 16.04, 18.04
CPU SSE2 명령어 집합 지원이 포함된 x86, x64 아키텍처 SSE2 명령어 집합 지원이 포함된 x64 아키텍처 SSE2 명령어 집합 지원이 포함된 아키텍처
GPU 명시적 GPU 지원 없음
추가 요구 사항 하드웨어 공급업체가 공식적으로 지원하는 드라이버

WebGL

브라우저를 실행하는 운영체제 Windows, macOS, Linux
하드웨어 워크스테이션 및 노트북 폼 팩터.
추가 요구 사항 다음의 Chrome, Firefox 또는 Safari 버전:
- WebGL 1.0 또는 2.0 지원
- HTML 5 표준 준수
- 64비트
- WASM 지원

XR 플랫폼 시스템 요구 사항

XR 관리 패키지를 사용하는 XR 플러그인 아키텍처로의 마이그레이션의 일환으로 빌트인 플랫폼 패키지는 Unity 2019.3 이상 버전에서 지원 중단될 예정입니다.

이러한 구현은 Unity 패키지 관리자에서 계속 작동하고 사용할 수 있지만, 버그와 문제의 우선 순위가 지정되지 않고 패키지가 향후 릴리스에서 제거될 수 있습니다.

Unity 2019.3+의 Google Daydream/Cardboard, OpenVR 및 Vuforia 지원 옵션에 대한 내용은 XR 플러그인 아키텍처 페이지를 참조하십시오.

Oculus

여기에는 Oculus Rift/Rift S, Oculus Go, Oculus Quest 및 Samsung Gear VR에 대한 시스템 요구 사항이 포함됩니다.

하드웨어 Oculus Rift/Rift S Oculus Go Oculus Quest Samsung Gear VR
운영체제 버전 Windows 10 Android Android Samsung Android 5.0/Lollipop+
CPU Intel 64비트 ARM 64비트(Snapdragon 821) ARM 64비트(Snapdragon 835) ARM 64비트(Snapdragon 821)
GPU NVIDIA GTX 1050Ti/AMD Radeon RX 470 이상 해당 없음
그래픽스 API DX11, OpenGL OpenGL ES 3.0+, Vulkan OpenGL ES 3.0, Vulkan OpenGL ES
추가 요구 사항 지원되는 최신 SDK 버전: 1.38.
XR 관리Oculus XR 플러그인 패키지를 사용하십시오.

Windows Mixed Reality

여기에는 WMR Immersive (VR), HoloLens 및 HoloLens Remoting에 대한 시스템 요구 사항이 포함됩니다.

하드웨어 WMR Immersive (VR) HoloLens HoloLens Remoting
운영체제 버전 Windows 10 RS4 Windows Holographic Windows 10 RS4
CPU Intel 64비트 Intel Atom Intel 64비트
그래픽스 API DX11 해당 없음
추가 요구 사항 지원되는 SDK 버전: 10.0.17134.0.
XR 관리Windows XR 플러그인 패키지를 사용하십시오.

Magic Leap

여기에는 Magic Leap One 및 Magic Leap Remoting에 대한 시스템 요구 사항이 포함됩니다.

운영체제 Magic Leap One Magic Leap Remoting
운영체제 버전 Lumin OS Windows 10 RS3, macOS El Capitan 10.11.6+
CPU Nvidia Tegra X2 Intel 64비트
GPU 해당 없음 Nvidia, AMD
그래픽스 API OpenGL ES 3.2+ 해당 없음
추가 요구 사항 지원되는 최신 SDK 버전: 0.18.0

ARCore

여기에는 Android 스마트폰, iPhone 및 iPad에 대한 시스템 요구 사항이 포함됩니다.

운영체제 Android 스마트폰 iPhone 및 iPad
운영체제 버전 7 iOS 11
CPU ARM 64비트 A9+
그래픽스 API OpenGL ES Metal
추가 요구 사항 지원되는 최신 SDK 버전: 1.9

ARKit

여기에는 iPhone 및 iPad에 대한 시스템 요구 사항이 포함됩니다.

운영체제 iPhone 및 iPad
운영체제 버전 iOS 11
CPU A9+
그래픽스 API Metal
추가 요구 사항 지원되는 최신 SDK 버전: ARKit 3 베타

기타 시스템 요구 사항 참고

Windows 7을 지원하는 Unity 에디터 또는 플레이어의 경우 Windows 7에 대한 Microsoft 지원이 2020년 1월 14일에 만료된다는 점에 유의하십시오.

Unity 설치
Unity 허브