Version: 2021.1
Setting Up Your Scripting Environment
Unity에서 C# 코드 디버깅

통합 개발 환경(IDE) 지원

통합 개발 환경(IDE)은 컴퓨터 소프트웨어의 일종으로, 다른 소프트웨어를 쉽게 개발하는 데 도움이 되는 툴과 기능을 제공합니다. Unity는 다음의 IDE를 지원합니다.

Visual Studio(Windows 및 macOS의 기본 IDE)

Visual Studio is installed by default when you install Unity on Windows and macOS. On Windows, you can choose to exclude it when you select which components to download and install. Visual Studio is set as the External Script Editor in Preferences (menu: Edit > Preferences > External Tools > External Script Editor). With this option enabled, Unity launches Visual Studio and uses it as the default editor for all script files.

macOS에서는 Visual Studio for Mac이 C# IDE로 포함됩니다. Visual Studio Tools for Unity(VSTU)는 Visual Studio for Mac(VS4M)을 위한 Unity 통합을 제공합니다. Visual Studio for Mac을 설치하고 사용하는 방법은 다음 Microsoft 문서 페이지를 참조하십시오.

Windows에서 Unity는 Visual Studio 2017 Community도 포함합니다.

Visual Studio Code(Windows, macOS, Linux)

Unity supports opening scripts in Visual Studio Code (VS Code). To open scripts in VS Code, select it as the External Script Editor in the Editor Preferences (menu: Edit > Preferences > External Tools > External Script Editor). For information on using VS Code with Unity, see Visual Studio’s documentation on Unity Development with VS Code.

선행 조건

C# 코드 편집 및 Unity C# 디버깅 지원을 위해 Visual Studio Code를 사용하려면 다음을 설치해야 합니다.

JetBrains Rider(Windows, macOS, Linux)

Unity supports opening scripts in JetBrains Rider. To open scripts in Rider, select it as the External Script Editor in the Editor Preferences (menu: Edit > Preferences > External Tools > External Script Editor).

Rider는 ReSharper를 기반으로 빌드되었으며 ReSharper의 기능을 대부분 포함하고 있습니다. Unity에서 .NET 4.6 스크립팅 런타임에서 C# 7.2의 모든 기능뿐만 아니라 C# 디버깅도 지원합니다. 자세한 내용은 Unity용 Rider의 JetBrains 문서를 참조하십시오.


  • 2019–04–18 페이지 게시됨
Setting Up Your Scripting Environment
Unity에서 C# 코드 디버깅