Unity 2017.2로 업그레이드(Upgrading to Unity 2017.2)
Unity 5.6으로 업그레이드(Upgrading to Unity 5.6)

Unity 2017.1로 업그레이드

이 페이지에는 이전 Unity 버전에서 2017.1로 업그레이드할 경우 기존 프로젝트에 영향을 미칠 수 있는 변경 사항이 나열됩니다.

예를 들면, 다음과 같습니다.

  • 데이터 포맷 변경. 이로 인해 다시 베이크해야 할 수 있음

  • 기존 함수, 파라미터 또는 컴포넌트 값의 의미 또는 동작 변경

  • 기능 지원 중단(대체 기능 제안)


UnityWebRequestTexture.GetTexture() nonReadable 파라미터 변경

이 편의 API에는 nonReadable을 true로 설정하면 읽기 가능한 텍스처가 얻어져야 하는(그 역도 성립함) 정상적인 작동이 반대로 작동하는 버그가 있었습니다. 이제 이 버그는 수정되었으며, 파라미터가 설명된 대로 작동합니다. DownloadHandlerTexture를 직접 만들 경우 이에 영향을 받지 않습니다.


파티클 시스템 스트레치 빌보드 피벗 파라미터 변경

X축 피벗은 이제 스트레치 빌보드에서 정확합니다. 영향을 받은 프로젝트에서는 피벗 설정을 다시 설정해야 할 수 있습니다.

Y축 피벗도 이제 정확하며 프로젝트를 업그레이드하면 Unity가 해당 피벗을 자동으로 다시 설정합니다.


셰이더 매크로 UNITY_APPLY_DITHER_CROSSFADE 변경

이 매크로는 프래그먼트 셰이더의 LOD 크로스 페이딩 오브젝트에 대한 스크린도어 디더링 효과를 구현하는 데 사용되었습니다. 이전에는 전체 프래그먼트 IN 구조를 전달해야 했지만, 이제는 스크린 포지션 벡터만 전달하면 됩니다.

2017.1 이후 새 dithercrossfade 옵션이 디더링 코드를 자동으로 생성할 수 있는 #pragma surface 지시문에 대해 추가되었습니다.



* 2018–04–12 편집 리뷰 없이 페이지 수정됨

Unity 2017.2로 업그레이드(Upgrading to Unity 2017.2)
Unity 5.6으로 업그레이드(Upgrading to Unity 5.6)