2D/3Dプロジェクト
Learn 画面

はじめに

Unity を初めて起動する

Unity エディターを立ち上げると、ホーム画面が表示されます。コンピューターに Unity プロジェクトがなかったり、Unity を初めて開く場合は、ホーム画面に Learn タブが表示されます。

The Learn tab in the Home Screen
The Learn tab in the Home Screen

Learn タブから、Unity を使い始めるのに役立つチュートリアルや学習リソースにアクセスできます。Unity に慣れていない場合は、新しいプロジェクトを始める前に Unity Learn のチュートリアルをひととおりやってみるとよいでしょう。

Projects タブ

ホーム画面から、 Projects をクリックすると Projects タブを表示できます。

ホーム画面の Learn タブ
ホーム画面の Learn タブ

新しいプロジェクトを開くには、 New をクリックします。これにより、 Create Project ビューが開きます。

コンピューターに既に存在する Unity プロジェクトを開くには、Projects タブでプロジェクトの名をクリックするか、 Open をクリックしてコンピューター内のプロジェクトフォルダーをブラウズします。

Unity Collaborate プロジェクトにアクセスするには、In The Cloud をクリックし、それから、読み込みたいプロジェクトを選択します。その後、このプロジェクトの保存場所をコンピューター内で選択するようメッセージが出ます。

プロジェクトの作成

このホーム画面の右上角で、 ‘New’ をクリックして 新規作成画面 を表示します。

Unity エディターをすでに立ち上げているときにホーム画面を呼び出したい場合は、 File メニューから New Project … を選んでください。

新規作成画面 では、プロジェクトを作成する前に適用するさまざまな初期設定があります。 詳細は、下で説明します。

ホーム画面の新規作成画面
ホーム画面の新規作成画面
設定 機能
Project name プロジェクトの名前を設定します。これによって、アセット、シーン、プロジェクトに関連する他のファイルを格納するフォルダー名を決定します。デフォルトでは New Unity Project となっており、いつでも変更することができます。
Location プロジェクトを格納するコンピューターのファイルシステムの場所を設定します。デフォルトでは、 コンピューターのホームフォルダーになっています。変更するには、 Location フィールドにファイルを保存したい場所のファイルパスを入力します。また、 Location フィールドの 3つの青い点をクリックし、コンピューターのファイルブラウザを開いてパスを指定することもできます。(コンピューターのオペレーティングシステムによって Explorer、Finder、Files のいずれか)。ファイルブラウザで、プロジェクトを格納するフォルダーを探し、 Select FolderOpen をクリックします。
3D / 2D 3D か 2D を選び、プロジェクトの種類を決めてください。これによって、簡単にプロジェクトを開始するための Unity の様々なプリセットが設定されます。デフォルトでは 3D 設定になっています。どちらに設定したら良いか判らない場合は、 3D のままにしておくのが良いでしょう。この設定は後から変える事ができます。 後でこの設定を変更する場合は、 Scene ビュー の 2D ボタンをクリックします。
Add Asset Package オプションから、プロジェクトに含めるアセットパッケージを選択することができます。 アセットパッケージというのは作成済みの画像、スタイル、ライティングエフェクト、ゲーム内でのキャラクター制御やゲーム制作で役に立つツールやコンテンツを指します。

最初から付属アセットをインポートしたい場合は、 Add Asset Package ボタンを選択し、表示される利用可能なアセットのリストから、インポートしたいものを選んで Done をクリックしてください。プロジェクトが作成されたら Unity が自動的に選択したアセットをインポートします。Add Asset Package 画面にもまた、Unity Asset Store からダウンロードしたアセットすべてが表示されます。

いったんプロジェクトを作成したら、あとから、アセットパケージを加えることもできます。それを行うには、 Assets > Import Package の順に選び、インポートしたいパッケージを選択します。

Create project を押せば準備完了です。 Unity は自動的に必要なファイルを生成し、プロジェクトを作成します。

プロジェクトを開く

ホーム画面の Project タブには、以前にコンピューター上で開いたすべてのプロジェクトがリストされています。プロジェクトの1つをクリックすると開きます。

 Projects タブにリストされたプロジェクト
Projects タブにリストされたプロジェクト

エディターが新しくインストールされたり、まだ、プロジェクトを一度も開いたことがない場合は、 Open をクリックしファイルブラウザを開き、プロジェクトフォルダーを探します。Unity プロジェクトは、1 つの特別な Unity プロジェクトファイルというよりは、ファイルとディレクトリの集まりです。プロジェクトを開くには、特定のファイルというよりは、メインのプロジェクトフォルダーを選択してください。

Unity エディター内からホーム画面の Projects タブを呼び出したい場合は、 File > Open Project の順に選んでください。




  • 2017–05–18 編集レビュー を行ってパブリッシュされたページ

  • Learn タブを 5.6 に追加

2D/3Dプロジェクト
Learn 画面