네트워크 에뮬레이션
RenderDoc 통합

Visual Studio C# Integration

이 기능으로 무엇을 얻을 수 있나요?

더 정교한 C# 개발 환경을 얻을 수 있습니다. 스마트 자동 완성, 컴퓨터 보조 소스 파일 변경, 스마트 구문 하이라이트 등을 예로 들 수 있습니다.

Express와 Pro의 차이점은 무엇인가요?

VisualStudio C# 2010 is a product from Microsoft. It comes in an Express and a Profesional edition. The Express edition is free, and you can download it from here.
The Professional edition is not free, you can find out more information about it here.

Unity의 VisualStudio 통합으로 VisualStudio 프로젝트 파일을 자동적으로 만들고 유지할 수 있습니다. Unity 콘솔에서 스크립트나 오류 메시지를 두 번 클릭해도 VisualStudio가 열립니다.

Visual Studio Express를 갖고 있는데 어떻게 사용하나요?

  • Unity의 Assets->Sync MonoDevelop Project 메뉴에서 선택합니다.
  • 새로 만든 .sln 파일을 Unity 프로젝트에서 찾습니다(Assets 폴더의 한 단계 상위 폴더).
  • Visual Studio Express로 파일을 엽니다.
  • 이제 모든 스크립트 파일을 편집하고 Unity로 다시 전환하여 사용할 수 있습니다.

I’ve got Visual Studio Profesional, how do I use it?

  • Unity에서 Edit->Preferences로 이동하여 Visual Studio가 기본 외부 에디터로 선택되었는지 확인합니다.
  • 프로젝트에서 C# 파일을 두 번 클릭합니다. Visual Studio에서 파일이 자동으로 열립니다.
  • 파일을 편집한 후 저장하고 Unity로 다시 전환할 수 있습니다.

다음 사항에 주의해야 합니다.

  • Even though Visual Studio comes with its own C# compiler, and you can use it to check if you have errors in your c# scripts, Unity still uses its own C# compiler to compile your scripts. Using the Visual Studio compiler is still quite useful, because it means you don’t have to switch to Unity all the time to check if you have any errors or not.

  • Visual Studio의 C# 컴파일러에는 Unity의 C# 컴파일러에 현재 있는 기능보다 많은 기능이 있습니다. 따라서 일부 코드(특히 새로운 C# 기능)는 Visual Studio에서 오류를 발생시키지 않지만 Unity에서는 오류를 발생시킵니다.

  • Unity는 자동으로 Visual Studio .sln 및 .csproj 파일을 만들고 유지합니다. 누군가 Unity 안에서 파일을 추가/이름 변경/이동/삭제할 때마다 Unity는 .sln 및 .csproj 파일을 다시 생성합니다. Visual Studio에서 파일을 솔루션에 추가할 수도 있습니다. 그러면 Unity는 이 새로운 파일을 임포트하고, 다음 번에 Unity가 프로젝트 파일을 다시 만들 때 이 새로운 파일이 포함된 파일을 만듭니다.

  • Unity는 AssetServer 업데이트 또는 SVN 업데이트 후에 Visual Studio 프로젝트 파일을 다시 생성하지 않습니다. Assets->Sync MonoDevelop Project 메뉴를 통해 Visual Studio 프로젝트 파일을 다시 생성하도록 Unity를 수동으로 설정할 수 있습니다.

네트워크 에뮬레이션
RenderDoc 통합