Version: 2019.4
LanguageEnglish
  • C#

UnityAPICompatibilityVersionAttribute Constructor

Suggest a change

Success!

Thank you for helping us improve the quality of Unity Documentation. Although we cannot accept all submissions, we do read each suggested change from our users and will make updates where applicable.

Close

Submission failed

For some reason your suggested change could not be submitted. Please <a>try again</a> in a few minutes. And thank you for taking the time to help us improve the quality of Unity Documentation.

Close

Cancel

public UnityAPICompatibilityVersionAttribute(string version, bool checkOnlyUnityVersion);

Parameters

versionUnity version that this assembly is compatible with.
checkOnlyUnityVersionMust be set to true.

Description

Initializes a new instance of UnityAPICompatibilityVersionAttribute.

Use this overload during the development cycle to avoid the AssemblyUpdater check that is performed on game code built outside of Unity and imported as assemblies. You can also avoid this check by passing disable-assembly-updater as a command line argument (see the Unity Manual for more details).


Obsolete public UnityAPICompatibilityVersionAttribute(string version);

Parameters

versionUnity version that this assembly is compatible with.

Description

Initializes a new instance of UnityAPICompatibilityVersionAttribute. This overload has been deprecated.


public UnityAPICompatibilityVersionAttribute(string version, string[] configurationAssembliesHashes);

Parameters

versionUnity version that this assembly is compatible with.
configurationAssembliesHashesA comma-separated list comprised of the assembly name and attribute hash pairs. For example, assemblyname:hash,assemblyname:hash.

Description

Initializes a new instance of UnityAPICompatibilityVersionAttribute. This constructor is used by internal tooling.