Unity 5.0에서 베이크된 데이터
Unity 5.0의 물리

Unity 5.0의 플러그인(Plugins in Unity 5.0)

다음은 프로젝트에서 네이티브 오디오 플러그인을 사용하는 경우에 프로젝트를 Unity 4에서 Unity 5로 업그레이드할 때 주의해야 하는 참고 사항입니다.

플러그인은 더 이상 Assets\Plugins\<Platform> 폴더에 저장하지 않아도 되고, 이제 호환되는 플랫폼을 확인하는 설정과 플랫폼별 설정(호환 CPU, SDK 설정 등) 등을 포함합니다. 기본적으로, 새 플러그인은 ’모든 플랫폼’과 호환되는 것으로 표시됩니다. 구 Unity 버전에서 더 편리하게 전환할 수 있도록 Unity는 플러그인이 어느 폴더에 있는지 확인하고 초기 설정을 적절하게 설정합니다. 예를 들어, 플러그인이 Assets\Plugins\Editor에 있는 경우 에디터만 호환되는 것으로 표시되고, 플러그인이 Assets\Plugins\iOS에 있는 경우 iOS만 호환된다고 표시됩니다. ’PluginInspector 문서’에서도 자세한 내용을 참조하십시오.

에디터의 네이티브 플러그인

32비트 네이티브 플러그인은 64비트 에디터에서 작동하지 않습니다. 32비트 네이티브 플러그인을 로드하면 오류가 콘솔에 로그로 기록되고 네이티브 플러그인에서 함수를 호출하려고 하면 예외가 발생합니다.

에디터에서 32비트 네이티브 플러그인을 계속 사용하려면 (별도 설치 프로그램으로 제공되는)32비트 에디터 버전을 사용해야 합니다.

프로젝트에서 동일한 플러그인의 32비트 및 64비트 버전을 모두 사용하려면 간단히 각 버전을 2개의 다른 폴더에 넣고 임포터 설정에서 지원되는 플랫폼을 적절하게 설정해야 합니다.

제약:

  • 현재 OSX용 32비트 에디터는 제공되지 않습니다.

네이티브 오디오 플러그인

“audioplugin”(대소문자 구분 안 함) 접두사가 있는 플러그인은 오디오 믹서에서 사용할 수 있도록 스캔 시 자동으로 로드됩니다. 이런 플러그인이 시작 시 에셋이 로드되기 전에 로드되는 스탠드얼론 빌드에서도 마찬가지입니다. 스탠드얼론 빌드에서 오디오 믹서 같은 특정 에셋은 플러그인이 로드되어 있어야만 효과를 인스턴스화할 수 있습니다.

Unity 5.0에서 베이크된 데이터
Unity 5.0의 물리