FBX エクスポートガイド
Cinema 4D からオブジェクトをインポート

Maya からオブジェクトをインポート

Unity はネイティブで Maya ファイルをインポートします。始めるには、プロジェクトの Assets フォルダー内に .mb または .ma ファイルを置くだけです。 Unity に戻ると、シーンが自動的にインポートされ、プロジェクトビューに表示されます。

Unity でモデルを確認するには、 Project ビュー から Scene ビュー または Hierarchy ビュー にオブジェクトをドラッグするだけです。

Unity は現在、Maya から以下のものをインポートします。

  1. 位置、回転、スケールのあるすべてのノード。ピボットポイントおよび名前もインポートされます。
  2. 頂点色のあるメッシュ、法線および 2 つまでの UV セット
  3. テクスチャおよび拡散カラーを含むマテリアル。メッシュごとの複数マテリアル
  4. アニメーション FK & IK
  5. ボーンベースのアニメーション
  6. ブレンドシェイプ

Maya からブレンドシェイプ(モーフィング)をエクスポート

  1. ターゲットのエクスポートするメッシュに Blendshape が適用されていることを確認してください
  2. Maya のアニメーションキーフレームが必要な場合は任意の方法でブレンドシェイプノード上のキーフレームをアニメーション化してください
  3. FBX エクスポートダイアログでのモーフが必須の場合、スキンの animation > Deformations を確認してください。

アニメーションキャラクターに IK を使用している場合、Project ビュー でインポートした .mb ファイルを選択し、 InspectorImport Settings ダイアログで Bake IK & Simulation を選択します。

要件

Maya .mb および .ma ファイルをインポートするには、Unity を使用しているマシンに Maya をインストールして、.mb/.ma ファイルをインポートします。Maya 8.0 以降がサポートされています。

  • マシンに Maya をインストールせず、別のマシンから Maya ファイルをインポートしたい場合、Unity がネイティブにインポートできる FBX エクスポートガイド できます。最高の結果を得るには、->FBX 最新バージョン をインストールしてください。エクスポートするには、FBX エクスポートガイド を参照してください。

  • エクスポートされたら、Unity のプロジェクトフォルダーに fbx ファイルを置いてください。Unity は、自動的に fbx ファイルをインポートします。FBX エクスポートガイド で述べているように、インスペクターで FBX インポート設定をチェックします。

インポートプロセスの裏 (詳細)

Unity は Maya ファイルをインポートする際、バックグラウンドで Maya を起動します。Unity が Maya と通信し、.mb ファイルを Unity が読み込める形式へと変換します。Unity に最初に Maya ファイルをインポートする際、Maya をコマンドラインプロセスで起動します。これには約 20 秒かかりますが、次のインポートは非常に高速で行われます。

トラブルシューティング

  • シーンをシンプルにしたまま、Unity で必要なオブジェクトのみを含むファイルを試してみてください。
  • メッシュで問題が生じた場合、パッチ、NURBS 面などをポリゴンに変換したかを確認します (Modify > Convert + also Mesh > Quadragulate/Triangulate)。Unity はポリゴンのみサポートしています。
  • Maya で、まれにノード履歴が乱雑になることがありますが、その場合、モデルが正しくエクスポートできなくなることがあります。そのような場合には、 Edit->Delete by Type->Non-Deformer History を選択することで、この問題をとても簡単に修復できます。
  • Unity では、できる限り最新の FBX をサポートしています。もしモデルのインポートで問題が生じた場合、Autodesk Web サイト から最新版の FBX エクスポーターがあるか確認するか、もしくは FBX 2012 に戻してみてください。
  • Maya でのアニメーションベイキングは、ネイティブではなく、FBX を使って行われます。こうすることで、より複雑なアニメーションを適切に FBX 形式にベイクできます。ドリブンキーを使用している場合、アニメーションを正しくベイクするには、対象物に少なくとも 1 つのキーが設定してあることを確認してください。
FBX エクスポートガイド
Cinema 4D からオブジェクトをインポート