Version: 2021.3

UnityAPICompatibilityVersionAttributeConstructor

マニュアルに切り替える
public UnityAPICompatibilityVersionAttribute (string version, bool checkOnlyUnityVersion);

パラメーター

version このアセンブリが互換性を持つ Unity バージョン
checkOnlyUnityVersion True に設定する必要があります。

説明

UnityAPICompatibilityVersionAttribute の新しいインスタンスを初期化します。

開発サイクル中にこのオーバーロードを使用して、Unity の外部でビルドされ、アセンブリとしてインポートされたゲームコードに対して行われる AssemblyUpdater の確認を回避します。 コマンドライン引数として disable-assembly-updater を渡すことで、この確認を回避することもできます (詳細は、Unity マニュアルを参照してください)。


Obsolete public UnityAPICompatibilityVersionAttribute (string version);

パラメーター

version このアセンブリが互換性を持つ Unity バージョン

説明

UnityAPICompatibilityVersionAttribute の新しいインスタンスを初期化します。このオーバーロードは古く、非推奨です。


public UnityAPICompatibilityVersionAttribute (string version, string[] configurationAssembliesHashes);

パラメーター

version このアセンブリが互換性を持つ Unity バージョン
configurationAssembliesHashes アセンブリ名と属性のハッシュのペアで構成されるコンマ区切りのリスト。例えば、assemblyname:hash,assemblyname:hash

説明

UnityAPICompatibilityVersionAttribute の新しいインスタンスを初期化します。このコンストラクターは内部ツールによって使用されます。