Version: 2019.1 (switch to 2019.2b or 2018.4)
How do I Make a Skybox?
How do I make a Spot Light Cookie?
Other Versions

How do I make a Mesh Particle Emitter? (Legacy Particle System)

Mesh Particle Emitters are generally used when you need high control over where to emit particles.

For example, when you want to create a flaming sword:

  1. Drag a MeshThe main graphics primitive of Unity. Meshes make up a large part of your 3D worlds. Unity supports triangulated or Quadrangulated polygon meshes. Nurbs, Nurms, Subdiv surfaces must be converted to polygons. More info
    See in Glossary
    into the SceneA Scene contains the environments and menus of your game. Think of each unique Scene file as a unique level. In each Scene, you place your environments, obstacles, and decorations, essentially designing and building your game in pieces. More info
    See in Glossary
    .
  2. Remove the Mesh RendererA mesh component that takes the geometry from the Mesh Filter and renders it at the position defined by the object’s Transform component. More info
    See in Glossary
    by right-clicking on the Mesh Renderer’s InspectorA Unity window that displays information about the currently selected GameObject, Asset or Project Settings, alowing you to inspect and edit the values. More info
    See in Glossary
    title bar and choose Remove Component.
  3. Choose Mesh Particle Emitter from the Component->Effects->Legacy Particles menu.
  4. Choose Particle Animator from the Component->Effects->Legacy Particles menu.
  5. Choose Particle Renderer from the Component->Effects->Legacy Particles menu.

You should now see particles emitting from the mesh.

Play around with the values in the Mesh Particle Emitter.

Especially enable Interpolate Triangles in the Mesh Particle Emitter Inspector and set Min Normal Velocity and Max Normal Velocity to 1.

To customize the look of the particles that are emitted:

  1. Choose Assets->Create->Material from the menu bar.
  2. In the Material Inspector, select Particles->Additive from the shader drop-down.
  3. Drag & drop a texture from the Project viewA view that shows the contents of your Assets folder (Project tab) More info
    See in Glossary
    onto the texture slot in the Material Inspector.
  4. Drag the Material from the Project View onto the Particle SystemA component that simulates fluid entities such as liquids, clouds and flames by generating and animating large numbers of small 2D images in the scene. More info
    See in Glossary
    in the Scene ViewAn interactive view into the world you are creating. You use the Scene View to select and position scenery, characters, cameras, lights, and all other types of Game Object. More info
    See in Glossary
    .

You should now see textured particles emitting from the mesh.

See Also

Did you find this page useful? Please give it a rating:

How do I Make a Skybox?
How do I make a Spot Light Cookie?